Geek.Like.Todd

netExtender and Ubuntu 12.04 Beta.. effing java —

Just a note.. you will get an error that there is no compatible libssl.so.6.. this is because it’s not called that, and it’s not where netExtender is expecting..

It expects it to be in /usr/lib/ , but it’s in fact in /usr/lib/i386-linux-gnu

so.. we make some symbolic links..


sudo ln -s /usr/lib/i386-linux-gnu/libssl.so.1.0.0 /usr/lib/libssl.so.6
sudo ln -s /usr/lib/i386-linux-gnu/libcrypto.so.1.0.0 /usr/lib/libcrypto.so.6

Try your install again.. and …

Oh.. also.. remeber netExtenderGUI requires Java.. and Java and Ubuntu are kind of a fucking mess..

So.. I downloaded the JRE Bin from Java.com.. extracted it to /usr/lib/java and made a symbolic link to the /usr/lib/java/bin/java like so…

sudo ln -s /usr/lib/java/bin/java /usr/bin/java

So then.. Viola.. lol..


0

Categorised as: Geeking Out | Sad Truths


2 Comments

  1. Todd says:

    In 64 Bit Linux.. the command is this :

    sudo ln -s /lib/x86_64-linux-gnu/libssl.so.1.0.0 /lib/libssl.so.6
    sudo ln -s /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 /lib/libcrypto.so.6

  2. […] Credit where due, Geek.Like.Todd pointed me in the right direction on this: ¬†http://blog.geekliketodd.com/archives/962 […]

Leave a Reply

Your email address will not be published. Required fields are marked *